Current issue with stock adjustments in Portal

Incident Report for Front Systems Status

Postmortem

Date of incident: August 6, 2025
Timeframe: approx 15:00 – 15:50 CEST
Status: Resolved
Posted: August 7, 2025

What happened?

On the afternoon of August 6, we experienced a temporary issue in the Front Systems Portal where stock adjustments were duplicated. This affected all stock movements registered manually in the Portal or via the FrontZapp app. Sales transactions from the POS were not affected.

What caused it?

We’re in the process of upgrading and renewing hardware across our platform to improve performance and reliability. During the rollout of a new service setup, both the old and the new systems were unintentionally processing the same stock adjustments at the same time. This led to each stock movement being recorded twice.

What did we do to fix it?

  • The duplication issue was identified quickly and isolated within about 50 minutes.
  • Between 16:00 and 18:30, we automatically reversed all duplicate transactions to restore correct stock levels.
  • The root cause has been addressed, and our upgrade process has been updated to prevent similar issues in the future.

What do you need to do?

Most customers don’t need to take any action, but there are a few exceptions:

  • If you manually corrected stock levels during the incident (between 15:00–16:00), we recommend reviewing those adjustments, as they may need to be corrected again.
  • If you use real-time integrations (e.g. webhooks): Unfortunately, we cannot reverse the webhook events that were triggered during the incident. If your systems ingested these duplicate events, manual corrections will be required on your side.

Our apologies

We’re very sorry for the inconvenience this may have caused. We know how critical accurate stock is to your operations, and we take that responsibility seriously.

Posted Aug 07, 2025 - 12:25 CEST

Resolved

This incident has been resolved.
Posted Aug 06, 2025 - 15:53 CEST

Investigating

We are currently experiencing an issue in the Portal where stock adjustments are being duplicated. Our team is actively investigating and working to resolve the problem as quickly as possible.

We apologize for the inconvenience and appreciate your patience.
Posted Aug 06, 2025 - 15:15 CEST
This incident affected: Portal.