Sales Dashboard - Incorrect figures

Incident Report for Front Systems Status

Resolved

The issue has been fixed, hence resolving the Incident.
Posted Mar 02, 2026 - 15:50 CET

Update

We are continuing to investigate this issue.
Posted Mar 02, 2026 - 12:53 CET

Investigating

We are currently experiencing an issue where the sales figures displayed in the dashboard are incorrect. Our team is working to resolve the issue as quickly as possible.
Posted Mar 02, 2026 - 12:51 CET
This incident affected: Portal.