Visual issue with sales not appearing in POS Dashboard

Incident Report for Front Systems Status

Resolved

This issue has been resolved, and everything should be up and running as intended again.
Posted Jun 06, 2025 - 18:44 CEST

Investigating

We’re currently experiencing a visual issue with sales not appearing in the POS dashboard. Our team is actively working to resolve it as soon as possible.
Posted Jun 06, 2025 - 16:55 CEST
This incident affected: Point of Sales.