Issues with support line, preventing customers from calling in

Incident Report for Front Systems Status

Resolved

The incident has been resolved.
Posted Mar 05, 2025 - 15:39 CET

Investigating

We are currently experiencing issues with our support line, preventing customers from calling in.
Our team is actively investigating the issue and working to resolve it as quickly as possible.
If you need assistance, please reach out to us via email or chat.
Posted Mar 05, 2025 - 15:32 CET
This incident affected: General information.