Issue with budget display on the dashboard

Incident Report for Front Systems Status

Resolved

Our team fixed the issue and made some behind-the-scenes improvements to help prevent it from happening again.

Thanks for your patience, and we’re sorry for any confusion this caused.
Posted Jun 11, 2025 - 22:53 CEST

Investigating

We’re currently experiencing a visual issue affecting the budget display on the dashboard. Our team is actively working to resolve it as soon as possible.
Posted Jun 11, 2025 - 19:43 CEST
This incident affected: Portal.