Issues with our phone system
Incident Report for Front Systems Status
Resolved
The phone system is now operational again. We will continue to monitor the situation.
Posted Nov 13, 2024 - 16:56 CET
Investigating
Due to issues at Telenor our phone systems are not working as expected so you may experience problems getting through to Support. We apologize for the inconvenience!
You will be notified as soon as the phone-lines are back up.
Posted Nov 13, 2024 - 14:13 CET
This incident affected: General information.