Delays in dashboard

Incident Report for Front Systems Status

Resolved

Problem is resolved for now. We are currently investigating the root cause of the issue to avoid similar incidents moving forward
Posted Aug 18, 2025 - 09:01 CEST

Investigating

We’re currently experiencing a visual issue with sales not appearing in the POS dashboard. Our team is actively working to resolve it
Posted Aug 16, 2025 - 16:43 CEST
This incident affected: Point of Sales.