Issues with reporting system

Incident Report for Front Systems Status

Resolved

This issue has been resolved, and everything should be up and running as intended again.
Posted Jun 04, 2025 - 12:07 CEST

Investigating

We are currently experiencing issues with our reporting system. Our team is investigating the cause and will provide an update as soon as possible
Posted Jun 04, 2025 - 09:34 CEST
This incident affected: General information.