Keystone functions - partial outage

Incident Report for Front Systems Status

Resolved

We have determined that the reported issue did not affect functionality for the end users.
The issue was related to a health-check which started reporting issues but it turned out to be a false positive.
We have made some adjustments to the configuration to mitigate this.
Posted Jun 19, 2025 - 18:46 CEST

Investigating

We are currently experiencing issues with some of our back-end functions.
This may affect the following services:
-Dashboard and sales data updates in POS (sales are still processed correctly, so please continue selling as normal)
-Quick Insights in the Portal
-Printing of product labels from the Portal
-Webhook delivery delays
-Delays in other external integrations

We are investigating the issue.
Posted Jun 19, 2025 - 17:51 CEST
This incident affected: Point of Sales, Portal, and API.