Problems with printing labels

Incident Report for Front Systems Status

Resolved

This incident has been resolved.
Posted Feb 07, 2025 - 11:04 CET

Investigating

We are currently experiencing issues with label printing. Our team is investigating, and we will provide an update as soon as possible. Thank you for your patience.
Posted Feb 07, 2025 - 10:35 CET
This incident affected: Portal.