Issue with POS Dashboard

Incident Report for Front Systems Status

Resolved

The issue has been resolved and the POS dashboard is fully operational again.
Posted Jun 13, 2025 - 13:52 CEST

Investigating

We’re currently experiencing a visual issue with sales not appearing in the POS dashboard. Our team is actively working to resolve it as soon as possible.
Posted Jun 13, 2025 - 13:47 CEST
This incident affected: Point of Sales.