Issues with label printing and deliveries

Incident Report for Front Systems Status

Resolved

This incident has been resolved.
Posted May 08, 2025 - 08:49 CEST

Identified

We've identified the root cause and are actively working on a resolution
Posted May 07, 2025 - 15:24 CEST

Investigating

We are currently experiencing issues with label printing and deliveries. Our team is investigating, and we will provide an update as soon as possible. Thank you for your patience.
Posted May 07, 2025 - 14:23 CEST
This incident affected: Portal.